Elevated error rate for prefix-routing-consistency call of RIPEstat

Incident Report for RIPE NCC

Resolved

The issue has been resolved.

Our configuration change has led to a performance improvements in two areas. First, the p99 latency is now about 80% of what it was before the change. Additionally, some lookups that were previously failing are now completing successfully.
Posted Aug 29, 2025 - 07:36 CEST

Update

We are continuing to monitor for any further issues.
Posted Aug 28, 2025 - 17:50 CEST

Monitoring

We have deployed a fix. We are monitoring the performance.
Posted Aug 28, 2025 - 17:50 CEST

Identified

We are aware of an elevated error rate for the `prefix-routing-consistency` for some prefixes. The root cause is a performance issue with the underlying PostgreSQL server used for our IRR data.

We are working on a mitigation.
Posted Aug 28, 2025 - 17:07 CEST
This incident affected: Non-Critical Services (RIPEstat).