Finance systems not reachable

Incident Report for RIPE NCC

Resolved

The problem is fixed. It was with a third-party software we used, the problem is resolved on their end.
Posted May 06, 2024 - 22:49 CEST

Investigating

We are currently investigating this issue.
Posted May 06, 2024 - 22:15 CEST
This incident affected: Non-Critical Services (Billing & Payments).