Mailman is not available at the moment

Incident Report for RIPE NCC

Resolved

We have now fixed the issue and services have been restored. We will update the incident with a post-mortem report soon.
Posted Oct 03, 2025 - 13:37 CEST

Investigating

We are currently investigating this issue.
Posted Oct 03, 2025 - 12:46 CEST
This incident affected: Non-Critical Services (Mailing Lists).