The issue caused by an outage at one of our external vendors has now been resolved. During the incident, some users who attempted to contact the RIPE NCC may not have received a confirmation email or ticket number.
If you contacted us on Monday, 20 October and did not receive a confirmation email with a ticket number, please reach out to us again to ensure your request is properly registered.
Posted Oct 21, 2025 - 08:40 CEST
Investigating
We are experiencing issues when users attempt to create support tickets. We are investigating and will update this announcement once we know more. If you need to reach out to the RIPE NCC, please use the live chat feature on ripe.net and the LIR Portal.
Posted Oct 20, 2025 - 11:45 CEST
This incident affected: Email to/from the RIPE NCC and LIR (Member) Portal.