This issue has been resolved. We will work on the proposed mitigations soon.
Posted Aug 29, 2025 - 17:22 CEST
Monitoring
Around 12:35-12:40 UTC there was a severe increase in load on the RIPEstat application servers. This caused the application servers to start swapping, and performance to degrade. Between 14:00-14:05 requests started to fail.
The root cause seems to be a shift in request pattern.
The situation was complicated by a change in configuration management that meant we could not restart our application processes in big batches, but had to do this machine-by-machine.
As an intervention we will limit swap usage by our python processes to make failures (and recovery from failures) faster.
Posted Aug 29, 2025 - 16:45 CEST
Investigating
We are currently investigating this issue.
Posted Aug 29, 2025 - 15:48 CEST
This incident affected: Non-Critical Services (RIPEstat).