Invoices in the LIR Portal are temporary not visible

Incident Report for RIPE NCC

Resolved

This incident has been resolved.
Posted Sep 12, 2023 - 18:00 CEST

Investigating

We are currently investigating this issue.
Posted Sep 12, 2023 - 17:06 CEST
This incident affected: Non-Critical Services (Billing & Payments).