The datasets have been up to date since the last update. This incident has been resolved.
Posted Aug 03, 2024 - 16:02 UTC
Update
The backlog of dataset updates has been processed. Datasets are up to date again. We are continuing to monitor for any further issues.
Posted Aug 03, 2024 - 11:33 UTC
Monitoring
The HBase database recovery process has finished. Historical RIPEstat data is available again, but datasets have not been updated since yesterday 12:00 UTC. We are now working on updating the datasets.
Posted Aug 03, 2024 - 08:24 UTC
Identified
We are still facing issues with our HBase database. The recovery process is ongoing, but due to the data volume, may take an extended period of time. We will keep publishing updates here.
Posted Aug 03, 2024 - 08:05 UTC
Monitoring
The HBase database backing the data calls has partially recovered. A significant fraction of responses is failing. We are monitoring the situation.
Posted Aug 02, 2024 - 21:36 UTC
Update
The HBase database used for the data calls is still performing maintenance actions, which seem to be progressing. We do not know the duration of the recovery process. We will provide further updates tomorrow morning.
Posted Aug 02, 2024 - 21:15 UTC
Update
We are monitoring the status and recovery of the HBase database. We will provide another update later today.
Posted Aug 02, 2024 - 17:48 UTC
Update
The main deletion process, based on the progress of which we estimated the time the issue would resolve by, has finished. However, the database has not recovered yet. We are monitoring the status and progress of the HBase database.
We do not have a new ETA.
Posted Aug 02, 2024 - 14:03 UTC
Identified
The backend for many RIPEstat datasets (routing-related - except for looking glass, geolocation, IANA data lookup, Abuse lookup) is currently unavailable. This unavailability started around 12:00 UTC.
Today, after a migration earlier this week, we cleaned up old database tables. Unfortunately, this unexpectedly caused other tables to become unavailable. We expect the datasets to recover after ~13:45 UTC.
We will work on monitoring changes that will allow us to detect elevated error rates more easily in the future.
Posted Aug 02, 2024 - 12:42 UTC
This incident affected: Non-Critical Services (RIPEstat).