Issue Accessing Invoices in LIR Portal

Incident Report for RIPE NCC

Resolved

This incident has been resolved.
Posted Mar 10, 2023 - 16:41 CET

Monitoring

The issue is caused by intermittent errors accessing the 3rd party financial software but we have already reported this to the 3rd party.
Posted Mar 08, 2023 - 16:51 CET

Investigating

An issue in the LIR Portal is preventing some users from accessing or downloading their invoices. We are investigating.
Posted Mar 08, 2023 - 09:54 CET
This incident affected: Non-Critical Services (Billing & Payments) and LIR (Member) Portal.