Issues deleting CAs from RPKI dashboard
Incident Report for RIPE NCC
Resolved
We resolved the issue affecting the single, RIPE-NCC-controlled CA.

The root cause was data inconsistency that has been present for this CA since June 25 2015, that had not become apparent because we had not deleted this CA.

Due to the policies around the RIPE NCC allocating the RIPE NCC, the various teams in software engineering do not have production accounts to test their applications. A single shared account is available for learning and development, the RIPE meeting network, and production testing by the SWE teams when needed.

We will re-prioritise our effort in the RPKI team to get production accounts (for automated testing and validation of production issues).
Posted Aug 30, 2023 - 08:29 UTC
Identified
We identified the issue. So far, we estimate that this issue affected only one RIPE NCC-controlled CA.
Posted Aug 30, 2023 - 07:57 UTC
Investigating
We are aware of issues that prevent at least _some_ users from deleting their CA. Please get in touch with us at [email protected] if you want to delete a CA.

We estimate these issues started with a release at 29-8 at 08:00 UTC. We are working on reproducing the issue in a test environment.
Posted Aug 30, 2023 - 07:24 UTC
This incident affected: RPKI (RPKI Dashboard).