We are investigating some DNSSEC issues, and hope to have a resolution soon.
Posted Aug 14, 2025 - 15:26 CEST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 14, 2025 - 10:00 CEST
Scheduled
The www.ripe.net website will undergo maintenance work to support future improvements. During this time, the site may be temporarily unavailable or slower than usual.
Posted Aug 13, 2025 - 16:48 CEST
This scheduled maintenance affected: www.ripe.net.