Issues with Invoices in LIR Portal

Incident Report for RIPE NCC

Resolved

This incident has been resolved.
Posted Mar 15, 2023 - 10:24 CET

Monitoring

An issue in the LIR Portal is preventing some users from accessing or downloading their invoices. We are investigating. The issue is caused by intermittent errors accessing the 3rd party financial software, but we have already reported this to the 3rd party.
Posted Mar 13, 2023 - 12:35 CET
This incident affected: Non-Critical Services (Billing & Payments) and LIR (Member) Portal.