RIPEstat migration to new backend cluster
Incident Report for RIPE NCC
Resolved
As we expected, the delay for the final dataset recovered around 20:30 UTC. The system has been performing as expected since.
Posted Nov 21, 2024 - 06:13 UTC
Update
We have completed the migration and are monitoring the situation. We expect our final process to finish processing by midnight UTC.
Posted Nov 20, 2024 - 17:52 UTC
Monitoring
Over the last months, we have been working on migrating the database systems behind RIPEstat to a new cluster. After facing several issues, we postponed the migration multiple times.

Today we will continue with the migration. This will not be a user-visible change except for the available data for two datasets.

We decided not to import the full historical data for the datasets behind the bgp-state, bgp-updates, and bgplay API calls. For these datasets, the data starting from the 1st of July is available.

Please let us know (on [email protected]) if you have use cases for a long history of bgp-state/bgp-updates/bgplay data. Depending on the input we receive, we will consider how far we backfill this data.
Posted Nov 20, 2024 - 12:13 UTC
This incident affected: Non-Critical Services (RIPEstat).