We have decided to postpone the move of our largest datasets (HBase) to a new environment by one month. Due to the complexity of this migration, we wanted to ensure that RIPEstat would continue operating, and did not feel confident going ahead when this could result in the service being severely disrupted.
We plan to publish a RIPE Labs article with more details soon, including which historical data will be delayed when the migration is fully completed.
We are unable to export historical data for four of our data sets, out of a total of twenty. As a result, we will not be able to provide aggregated historical data for the following API calls and their corresponding widgets for some time after we complete our migration. The migration for the remaining data is ongoing:
We continue to face both software issues and degraded hardware performance during the data export from our HBase database. However, application error rates have returned to normal levels.
Posted Sep 20, 2024 - 16:33 UTC
Update
We continue to face issues during the export of data.
Posted Sep 19, 2024 - 15:34 UTC
Identified
The performance of multiple RIPEstat data sources is currently degraded due to maintenance preparations. We are exporting RIS-related datasets from our database (HBase) to prepare for a migration to a new environment. This export causes a high load on our production environment that noticeably impacts performance.
We apologise for the inconvenience this may cause as the preparation continues until the end of the month when we plan to have all datasets migrated.
Posted Sep 18, 2024 - 09:14 UTC
This incident affected: Non-Critical Services (RIPEstat).