RIS dump files (bview) for some RRC are not being generated

Incident Report for RIPE NCC

Monitoring

We patched our code to seamlessly handle the packets with malformed OTC attribute.
The backlog of data is now being processed.
Posted Oct 10, 2025 - 18:06 CEST

Identified

The problem is caused by the processing of malformed BGP updates.
These malformed BGP updates contain a 1024 bytes-long optional transitive attribute (OTC, type code 35), whereas the length should be 4 bytes.
Posted Oct 08, 2025 - 13:14 CEST

Investigating

RIS dumps files for a list of collectors (rrc00, rrc12, rrc20, rrc21, rrc25, rrc26) are not being produced.
These files, MRT TABLE_DUMP_V2 format (RFC 6396), are normally generated every 8 hours, at 0:00, 8:00, and 16:00 UTC.
The latest available bview files for the mentioned RRCs were produced at 16.00 UTC of Tuesday October 7th.

We are investigating.
Posted Oct 08, 2025 - 10:58 CEST
This incident affects: Non-Critical Services (RIS (Routing Information Service)).