Low rate of failing requests to stat.ripe.net

Incident Report for RIPE NCC

Resolved

The SSL certificate on one of our backend machines was updated, but the webserver had not picked up the certificate.

As a result we will improve our org-wide monitoring setup to:
* Monitor individual machines behind a load balancer over HTTPS for the production hostname
* Monitor SSL expiry based on these requests
* Monitor that our configuration management (salt) is successfully running
* Monitor https://stat.ripe.net through the loadbalancer and check for http errors and expired tls certificate, and alert when a single request fails
Posted Feb 24, 2025 - 16:09 CET

Investigating

We see a low rate of failed HTTP requests (due to an expired SSL certificate) for https://stat.ripe.net. We are investigating the situation.
Posted Feb 24, 2025 - 15:06 CET
This incident affected: Non-Critical Services (RIPEstat).