A fix has been implemented and we are monitoring the results.
Posted Feb 19, 2026 - 09:01 CET
Update
We are continuing to investigate this issue.
Posted Feb 19, 2026 - 09:01 CET
Investigating
Between approximately 1:00 to 9:00 CET today, there were some failures updating the RIPE database through mailupdates. We are investigating the cause(s).