Billing and Payment system intermittently unavailable

Incident Report for RIPE NCC

Resolved

Payment confirmation functionality has returned and invoices are available. The incident has been resolved.
Posted Jul 17, 2026 - 16:16 CEST

Update

We are continuing to investigate this issue.
Posted Jul 17, 2026 - 07:34 CEST

Investigating

Invoices may not be available in the LIR Portal and payment confirmation is delayed.
Posted Jul 16, 2026 - 09:40 CEST
This incident affected: Non-Critical Services (Billing & Payments) and LIR (Member) Portal.